Search The Hostwinds Guides Knowledge Base

Joomla! System Requirements

When installing Joomla, there are certain requirements which must be met for Joomla to run as there are different versions of Joomla. This article is written to be useful for the newest version the time of writing. This is Joomla 3.x, where ‘x’ is a number that helps to describe the current version. The Base and Recommended Requirements for Joomla to Function are listed below.

 

Joomla! Base System Requirements

  • PHP Version: Must be higher than PHP Version 5.3.10. This should not be a problem, as this version is long deprecated. All of our New Hosting Plans do not have this version installed.
  • Database: Joomla has support for different kinds of databases. The supported Databases are MySQL / MariaDB, MS SQL Server and PostgreSQL
    • MySQL / MariaDB: Must be higher than version 5.1. Another version that would not exist on our New Hosting Plans.
    • MS SQL Server: Must be higher than version 10.50.1600.1
    • PostgreSQL: Must be higher than version 8.3.18
  • Web Server: Along with the different kinds of databases that Joomla supports, there are also different types of web servers. These include, Apache, Nginx, and Microsoft IIS (for Windows VPS)
    • Apache: Must be higher than version 2.0. Our Shared / Business hosting plans will always have a relatively up to date version of Apache, so this is not a problem.
    • Nginx: Must be higher than version 1.0. We currently do not use Nginx, however this is still an option for VPS and Dedicated Servers.
    • Microsoft IIS: Must be version 7. This would be the Windows Operating System equivalent, however currently only available on Windows VPS or Dedicated Servers.

Joomla does not specify any specific requirements for the server such as RAM, or even CPU. However if you do tend to run into performance issues with your Joomla site, it may be because of lack of resources.

 

Aside from the Base System Requirements that Joomla has, there may be recommended options as well. The Base Requirements are a minimal to see if Joomla will run on the system. However this does not mean that Joomla will run optimally or well. You can find a list below of the recommended requirements for Joomla.

 

Joomla! Recommended System Requirements

  • PHP Version: Joomla recommends that you would use a PHP Version that is either 5.6 and up, or 7.0 and up.
  • Database:
    • MySQL / MariaDB: Recommended to be higher than MySQL 5.5.3
    • MS SQL Server: Also recommended to be higher than 10.50.1600.1
    • PostgreSQL: Recommended to be higher than version 9.1
  • Web Server: 
    • Apache: Recommended to be higher than Apache 2.4. Our newer Hosting plans will have this recommendation met
    • Nginx: Recommended to be higher than version 1.8
    • Microsoft IIS: For Joomla, they would recommend that only version 7 is used

 

Any Linux web hosting package offered by Hostwinds can meet these requirements.

 

If you should have any further questions, do not hesitate to contact us through our Live Chat, or by submitting a ticket.